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Tekla Structures configurations

Tekla Structures is available in different configurations that provide specialized
sets of functionalities to suit the needs of the construction industry. Tekla
Structures can be used to cover the entire building process from conceptual
design to fabrication, erection and construction management.
Special student and developer configurations of Tekla Structures are available.
Visit the main Tekla website for more information on student configurations
for home and classroom use. Visit the Tekla Developer Center for more
information on the Tekla Partners program.
The help covers the content of the Full configuration. Note that the
configuration that you are using may not contain all the described features.
Feature map
The features included in different configurations are:
Configuration
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Viewing

✔

✔

✔

✔

✔

✔

✔

✔

✔

Grids,
construction
lines, points

✔

✔

✔

✔

✔

✔

✔

✔

✔

Building
elements

✔

✔

✔

✔

✔

✔

✔1

Assemblies

✔

✔

✔

✔

✔

✔

✔

✔

✔

✔2

✔2

Feature

Precast cast units ✔

✔

Pour modeling

✔2

✔2
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Pour viewing
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✔2

✔2
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✔2

✔2

✔

✔

✔6

✔

✔3

✔

✔

✔2

Cast in Place cast ✔
units
Numbering

✔

Assigning control ✔
numbers
Conceptual
components
✔

Concrete
components

✔

Lotting

✔

Sequencer
User-defined
attributes

✔2

✔2

✔
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✔
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components
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✔
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✔
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✔
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✔

✔

✔

✔

✔

✔

✔

✔

✔

Project status
✔
visualization (4D)

✔

✔

✔
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✔

✔

✔

✔

Multi-user

✔

✔
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✔

✔
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Locking
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✔
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✔

Clash check
manager

✔

✔
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✔

✔

✔

Task manager

✔

✔

✔

✔

✔

✔

✔

✔

✔

Organizer

✔

✔

✔

✔

✔

✔

✔

✔

✔

✔4
✔

✔

Printing and publishing
Printing and
plotting

✔

✔

✔

✔

✔

✔

✔

✔

✔

Publish models

✔

✔

✔

✔

✔

✔

✔

✔

✔

Symbol Editor

✔

✔

✔

✔

✔

✔

✔

✔

✔

✔

Template Editor

✔

✔

✔

✔

✔

✔

✔

✔

✔

✔

External editors

Drawings, plans and reports
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Creating general ✔
arrangement
drawings (plan,
section, erection)

✔

✔

✔

✔

✔

✔

✔

Modifying
✔
general
arrangement
drawings (plan,
section, erection)

✔

✔

✔

✔

✔

✔

✔

Creating steel
fabrication
drawings (singlepart drawings)

✔

✔

✔

✔

Modifying steel
fabrication
drawings (singlepart drawings)

✔

✔

✔

✔

Creating steel
fabrication
drawings
(assembly
drawings)

✔

✔

✔

✔

Modifying steel
fabrication
drawings
(assembly
drawings)

✔

✔

✔

✔

Creating precast
concrete
drawings (cast
unit drawings)

✔

✔

✔

✔

Modifying
precast concrete
drawings (cast
unit drawings)

✔

✔

✔

✔

Creating cast-inplace concrete

✔

✔

✔

✔
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drawings (cast
unit drawings)
Modifying cast-in- ✔
place concrete
drawings (cast
unit drawings)

✔

✔

✔

✔

✔

Anchor bolt plans ✔

✔

✔

✔

✔

✔

✔

Reports

✔

✔

✔

✔

✔

✔

✔

Export CNC, DSTV ✔

✔

Steel MIS links

✔

✔

Import 2D and
3D DWG, DXF

✔

✔

✔

✔

Export 3D DWG,
DXF, DGN

✔

✔

✔

Export drawings
(DXF, DWG)

✔

✔

Import and
export CAD and
FEM packages

✔

IFC 2x3 export

✔

✔

✔

Interoperability
✔

✔

✔

✔

✔

✔

✔

✔

✔

✔

✔

✔

✔

✔

✔

✔

✔

✔

✔

✔

✔

✔

✔

✔

✔

✔

✔

✔

✔

✔

✔

✔

✔

✔

CIS/2 import and ✔
export

✔

✔

✔

✔

✔

✔

EliPlan import
and export

✔

✔

BVBS export

✔

✔

HMS export

✔

Unitechnik
export

✔

View reference
models

✔

✔

✔

✔

✔

Attach reference
models (DXF,

✔

✔

✔

✔

✔
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Create analysis
model

✔

✔

✔

✔

✔

✔

Analysis and
Design interface

✔

✔

✔

✔

✔

✔

Loads

✔

✔

✔

✔

✔

✔

✔

✔

✔

✔

✔

Feature
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DWG, DGN, 3DD,
IFC, XML, PDF)
Analyzing

Open API
Open API
capabilities

✔

✔

✔

✔

✔4

✔1 = Limitation: 2500 parts, 5000 reinforcing bars + reinforcing bar groups,
unlimited number of bolts.
✔2 = Pours are enabled by an advanced option.
✔3 = Numbering is limited to cast-in-place parts, cast units and reinforcing
bars.
✔4 = View only.
✔5 = Only Cast in Place concrete components.
✔6 = Numbering is limited to steel parts and cast units.
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2

Install and license Tekla
Structures

To use Tekla Structures, you need to have a license to use the product, the
Tekla Structures installed on your computer and in most cases also a Trimblesupplied or customized Tekla Structures environment that contains many
different settings and tools, such as profiles, templates and components.
Click to expand the section relevant to you and follow the links in the text for
detailed instructions.
Tekla Structures licenses
Tekla Structures cannot be used without a valid license.
•

The full commercial versions of Tekla Structures are licensed by activating
an entitlement certificate on your license server. To get an entitlement
certificate, you need to buy a license. The entitlement certificate is sent in
an email to the contact person your organization has named when
purchasing the license. If you have purchased a license but have not
received your entitlement, please contact your local Tekla sales office or
reseller.

•

If you wish to learn how to use Tekla Structures, download and install the
Tekla Structures learning edition, which comes with a free license that is
connected to your user account at the Tekla Campus site. Note that any
model you save in the learning edition cannot be opened in the full
commercial version of Tekla Structures.

If someone manages Tekla Structures for you
•

You need an account to access Tekla online services. If your administrator
has not invited you to your organization, ask to join so that you have access
to all Tekla online services:
Create your Trimble Identity (page 12)

•

In most cases, your Tekla Structures administrator will prepare a
customized installation package for you or install the software for you. Ask
your administrator for further instructions.

Install and license Tekla Structures
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•

To be able to use Tekla Structures outside the office, you may need to know
how to borrow a license for offline use:
Borrowing Tekla Structures licenses for offline use

If you are a Tekla Structures learning (Tekla Campus) user
•

Create your Trimble Identity (page 12) and login to the Tekla Campus site
to access Tekla Campus and activate your learning license.

•

Download the installation package for Tekla Structures and at least one of
the Tekla Structures environments from the Tekla Campus site.
When you scroll down the page, there is also a video of how to install the
Tekla Structures Learning edition. Tekla Campus user account acts as
license key for Tekla Structures Learning configuration: no entitlement
certificate is needed.

•

Start your learning using the videos and examples available at the Tekla
Campus site.

If you manage your own installation of Tekla Structures
•

Create your Trimble Identity (page 12) to access all Tekla online services.

•

Download the installation package for Tekla Structures, the license server
and at least one of the Tekla Structures environments from Tekla
Downloads.

•

Install the license server software on your computer and activate your
license.

•

1.

Install Tekla Structures license server (page 22)

2.

Activate Tekla Structures licenses (page 23)

3.

Save your Tekla Structures license entitlement certificate (page 22)

4.

Connect Tekla Structures to the license server (page 24)

Install the Tekla Structures software and at least one of the Tekla Structures
environments on your computer:
Tekla Structures installation (page 12)

If you manage Tekla Structures for other users
The general workflow for a new Tekla Structures deployment can go for
example like this:
•

Install the Tekla Structures license server.

•

Install Tekla Structures for your own use and start customizing it for your
organization.

•

Deploy Tekla Structures to the users in your organization.

Install and license Tekla Structures
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•

Continue developing your organization's customizations and redeploy as
needed.

Start your journey in Tekla Structures installation for administrators, which
introduces you to all of the topics listed above.

2.1 Create your Trimble Identity
You need a Trimble Identity to download Tekla Structures.
Some Tekla online services require that your account is connected to an
organization that has a valid maintenance contract with Trimble. If you are the
named contact at your organization, Trimble automatically creates an account
for you or connects your existing Trimble Identity to your organization. The
named contact has administrator status and must add other users into the
organization to enable their access to content and services that require a valid
maintenance contract.
NOTE Membership in your organization also affects users' access to your
organization's cloud-stored data, such as Tekla Model Sharing models.
If you are the named contact, Trimble sends you an email with an invitation to
accept membership in the organization group and complete the profile
information if you did not have an existing Trimble Identity. You are then
responsible for managing the organization group together with other
administrators that you assign. See Managing Trimble Identities and Tekla
Model Sharing licenses for more information.
If you are not the named contact, you receive an email invitation to join the
organization group when an administrator from your own organization invites
you. You can also create a new Trimble Identity here.
If you are having problems using your Trimble Identity in Tekla online services,
see the troubleshooting information on this page.

2.2 Tekla Structures installation
Tekla Structures installation packages are available for download in Tekla
Downloads. In addition to installing Tekla Structures, you need to install and
set up a Tekla Structures license server and activate your Tekla Structures
license.
Tekla Structures software and environments are available as separate
installation packages. The software installation package always contains a
blank project (page 30) environment that includes generic content. Other
Tekla Structures environments are available as separate installation files.
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Create your Trimble Identity

Environments are region or company-specific settings and information that
are predefined in Tekla Structures, or that are defined by the user.
You can install the Tekla Structures license server on the same computer as
the Tekla Structures software and environments. The license server can also
be installed on a separate server computer if there are many Tekla Structures
users and many Tekla Structures licenses in the company. The licenses you can
use and their activation IDs are listed in an entitlement certificate you receive
via e-mail.
Tekla Structures uses the FlexNet Publisher License Management (FlexNet)
licensing system. The FlexNet licensing system is not used with Tekla
Structures Learning Edition, and FlexNet licensing instructions do not apply.
For more information about Tekla Structures Learning Edition, see Tekla
Campus.
Centralized installation
Tekla Structures can be installed across the company network using
centralized installation. Installing Tekla Structures centrally across the
company network saves time in a large company as the installation is done
silently in the background for each user.
Using Tekla Structures with application and desktop virtualization
Tekla Structures can be used with the Citrix application and desktop
virtualization. Tekla Structures is installed on a server or on a virtual machine
running on the server. Using Tekla Structures from the server ensures that all
users in a project are using the same project environment set-up.
Version updates: Service packs
Service packs are version updates that can contain new features, and
improvements and fixes to existing features.
Service packs are available in Tekla Downloads for all customers with a valid
maintenance agreement. We recommend that all users install the latest
service pack.
Borrowing licenses with License Borrow Tool
If you want to work offline and do not have the Tekla Structures license server
on your computer, you can borrow an activated license from the license server
(page 25) using the Tekla Structures License Borrow Tool. The borrowed
license is transferred from the license server to your computer. It is not
available for other users during the borrowing. The installer for Tekla
Structures License Borrow Tool is available in Tekla Downloads.
Collaboration within a Tekla Structures model
Multi-user mode allows several users to access the same model
simultaneously. Multi-user mode is suitable for local teams with projects
where the team members do not necessarily have an Internet connection. In
the multi-user mode a server computer runs the multi-user server, a file server
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Tekla Structures installation

computer contains the multi-user master model and client computers run
Tekla Structures. The Tekla Structures multi-user server installer is available in
Tekla Downloads.
Using the multi-user server requires your company to have more than one
Tekla Structures license.
Tekla Model Sharing also allows several users to access the same model
simultaneously. With Tekla Model Sharing a global team can work efficiently
within one model regardless of the team location and time zone. The model
data is shared and synchronized over the Internet, and stored to a cloudbased Tekla Model Sharing service. It is also possible to work offline. Tekla
Model Sharing requires a license.
Extensions
Extensions are applications that have been made using the Tekla Open API or
custom components. Extensions are not part of the Tekla Structures product
release. Extensions for Tekla Structures are available in Tekla Warehouse.
You can import the Tekla Structures extensions that have the .tsep (Tekla
Structures Extension Package) file extension to the Applications &
components catalog in Tekla Structures. The extensions are installed when
you restart Tekla Structures. Tekla Structures extensions that have the .msi
file extension have to be installed separately by running the installation file.
Tekla User Assistance
Tekla User Assistance collects all help and support material to one place. By
default, all help content is online. You can access Tekla Structures help
material in Tekla User Assistance by pressing the F1 button in Tekla Structures.
You can also use the help offline. Offline help installation packages are
available in Tekla Downloads.
See also
Tekla Structures installation prerequisites (page 14)
Tekla Structures installation folders (page 15)
Install Tekla Structures (page 20)

Tekla Structures installation prerequisites

Installing Tekla Structures requires one of the following operating systems:
Windows 10, Windows 8.1, or Windows 7 SP1.
The Tekla Structures installer is available as a 64-bit version.
Tekla Structures needs the following redistributable packages that are
automatically installed during the Tekla Structures software installation if they,
or newer versions of the packages, do not exist on your computer:
•

Microsoft .NET Framework 4.5.1

Install and license Tekla Structures

14

Tekla Structures installation

•

Microsoft Visual C++ 2010 Redistributable (x64) 10.0.40219

•

Microsoft Visual C++ 2010 Redistributable (x86) 10.0.40219

•

Microsoft Visual C++ 2013 Redistributable (x64) 12.0.40649

•

Microsoft Visual C++ 2013 Redistributable (x86) 12.0.40649

•

Microsoft Visual C++ 2015 Redistributable (x64) 14.0.23026

•

Microsoft Visual C++ 2015 Redistributable (x86) 14.0.23026

In addition, the following installers are automatically installed during the Tekla
Structures software installation:
•

Tsep File Dispatcher Launcher

•

Tekla Warehouse Service

These installers are needed to get Tekla Warehouse to work properly.
You can include the Tekla Warehouse offline content as .tsep packages (Tekla
Structures Extension Package) in the Tekla Structures software installation. If
you include the offline content, the.tsep packages are by default stored in the
C:\ProgramData\Tekla Structures\2018\Extensions\To be
installed folder. You can remove the .tsep packages that you do not need
by deleting them from the folder.
The .tsep installations are run when you start the new version of Tekla
Structures for the first time. The .tsep package contents are by default
installed in the C:\ProgramData\Tekla\Tekla Warehouse folder. When
you install the .tsep packages, you can use the Tekla Warehouse content
offline.
Tekla Warehouse offline content .tsep packages are available in the Tekla
Structures collections in Tekla Warehouse. If you do not include the offline
content in the Tekla Structures software installation, you can download the
content later from Tekla Warehouse.
Recommended hardware is described in Tekla Structures 2018 Hardware
Recommendations.
See also
Install Tekla Structures (page 20)

Tekla Structures installation folders

You can select the Tekla Structures software installation folder in the software
installation wizard. By default, the software is installed to a folder under
\Program Files\Tekla Structures\<version>.
When you install a new Tekla Structures version, for example 2018, make sure
that the installation folder does not contain any files from other Tekla
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Tekla Structures installation

Structures versions. This is to ensure that you get all the files that are included
in the installation package.
Note that when you are installing a service pack and you already have the
related Tekla Structures version or a previous service pack installed, you
cannot select the installation folder. The service pack will be installed to the
same folder as the related Tekla Structures version or the service pack that
you are updating. The installation folder will contain files from the related
Tekla Structures version or the previous service pack. Installing the new service
pack will automatically remove the old files before copying the new files. Note
that if you have your own files in the installation folder, these files will remain
unchanged in the folder.
The location of the environment installation folder depends on where you
have installed the software. You cannot select the installation folder for the
environments in the installation wizard. For example, when the software is
installed under \Program Files, the environments are installed in
\ProgramData\Tekla Structures\<version>\environments.
When you have installed the software and the environments, you can check
the installation paths in Windows Control Panel.
The image below shows the default installation folder structure under
\Program Files and \Program Data. User settings are stored under
\Users.
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The image below shows the installation folder structure under C:\. If you
install Tekla Structures software under C:\, the environments are also
installed and the user settings stored under C:\.
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NOTE If you need to install Tekla Structures to a folder that has a non-Unicode folder
name, for example, in Chinese, Japanese, Korean, or Russian, change the
language in XS_STD_LOCALE and the Windows system locale in Control panel
to that same language so that Tekla Structures can work normally.

The image below shows the installation folder structure of Tekla Warehouse
Content installation under C:\ProgramData\Tekla\Tekla Warehouse.
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See also
Install Tekla Structures (page 20)
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Install Tekla Structures

To use Tekla Structures, install the Tekla Structures software and the Tekla
Structures environments that you want to use.
You also need to have the Tekla Structures license server installed, either on
your own computer or on another computer, and you need to activate your
Tekla Structures license.
NOTE You need to be logged in with administrator rights to install the Tekla
Structures software on your computer.
1.

Install the Tekla Structures software.
a.

Download the installation file from Tekla Downloads to your
computer.

b.

Double-click the installation file to run the installation.

c.

Follow the steps in the installation wizard to complete the installation.
You can select the installation folder (page 15) and the model folder.

2.

Install the Tekla Structures environments.
Note that the location of the environment installation folder depends on
where you have installed the software. You cannot select the environment
installation folder in the installation wizard.
a.

Download the environment installation files from Tekla Downloads to
your computer.
Note that you can also later install as many environments as you
want to a Tekla Structures version that you are using.

b.

Double-click the installation file to run the installation.

c.

Follow the steps in the installation wizard to complete the installation.

See also
Tekla Structures installation prerequisites (page 14)
Tekla Structures installation folders (page 15)
Tekla Structures settings in Windows registry (page 20)

Tekla Structures settings in Windows registry

Windows registry is a hierarchical database that stores configuration settings
and options in Microsoft Windows operating systems. Registry settings are
used during a Tekla Structures session and during a Tekla Structures
installation.
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WARNING Do not change the registry settings. Changing the settings can
cause the operating system to fail. It is possible to view the
registry settings using the Registry Editor.
User settings
Some of the Tekla Structures user settings, for example, general options, and
dialog box locations and sizes are stored in the registry. The settings are saved
in a registry key named after the Tekla Structures version number in the
registry branch HKEY_CURRENT_USER\Software\Trimble\<VERSION>.
Tekla Structures uses the hardcoded default settings when opened for the first
time after the installation. If you change a setting during a Tekla Structures
session, Tekla Structures saves the change during the session, or when you
exit Tekla Structures. When you open the same version of Tekla Structures
again, the changed setting is used.
When upgrading to a newer Tekla Structures version, you can use the
Migration Wizard tool to copy the settings you have changed.
Installation settings
The Tekla Structures installation saves information to the
HKEY_LOCAL_MACHINE\SOFTWARE\Tekla\Structures\<VERSION> registry
key.
See also
Tekla Structures installation (page 12)

2.3 Taking Tekla Structures licenses into use
To take your Tekla Structures license server into use, follow the workflow
below:
1.

Install Tekla Structures license server (page 22)

2.

Save your Tekla Structures license entitlement certificate (page 22)

3.

Activate Tekla Structures licenses (page 23)

4.

Connect Tekla Structures to the license server (page 24)

NOTE When you set up the Tekla Structures licensing system, you may also need to
configure the firewall settings to be able to connect Tekla Structures to the
license server. For more information about configuring the firewall, see
Allowing Tekla Structures license server to operate through Windows
Firewall....
If you have problems, see Troubleshoot Tekla Structures licensing for more
information.
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Install Tekla Structures license server
Install the Tekla Structures license server. This is phase 1 in the workflow
Taking Tekla Structures licenses into use (page 21).
If you are using other FlexNet licensing services, you need to stop them before
you install the Tekla Structures license server. When you have completed
installing the Tekla Structures license server, you can restart the other
licensing services.
To install the license server:
1.

Go to Tekla Downloads and download the latest Tekla Structures license
server installation. To check the license server version to use, see Which
license server version to use.

2.

For standard setup, select the options Automatic and complete the
installation.
Tekla Structures license server is installed.
In automatic license server installation, the license server host name is
automatically set to 27007@your_host_name, where 27007 is the port
and your_host_name is your computer name.
Automatic installation is recommended. Use the Manual installation only
if you are an advanced user of FlexNet or Flexlm licensing, and you need
to change something in the default installation, for example, the TCP/IP
port. For more information, see Installing Tekla Structures license service manual installation

Save your Tekla Structures license entitlement certificate
Save your license entitlement certificate. This is phase 2 in the workflow Taking
Tekla Structures licenses into use (page 21).
As a preliminary action for transferring license rights from Trimble Solutions
license activation server to your license server, you need to save the
entitlement certificate, which is sent in an e-mail to the person in your
organization who has made the license purchase, or to someone named as
the contact person.
To save the license entitlement certificate:
1.

In your e-mail application, open the e-mail containing the entitlement
certificate.
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2.

Download the entitlement certificate file
EntitlementCertificate.html to the ..\TeklaStructures
\License\Server folder.

The entitlement certificate states the configurations, quantities and activation
IDs of your Tekla Structures licenses. The entitlement certificates are not
computer-specific. This means that you can activate licenses from several
entitlements on one license server and you can activate licenses from one
entitlement (containing several licenses) on several license servers.

Activate Tekla Structures licenses
Activate your Tekla Structures licenses. This is phase 3 in the workflow Taking
Tekla Structures licenses into use (page 21).
You need to activate the licenses on the license server to use Tekla Structures.
When you activate the licenses and notify the server, the license rights are
transferred from the activation server at Trimble Solutions to the license
server. Use Tekla Structures License Administration Tool for activating
licenses.
NOTE Do no use the automatic license server notification functionality if you
are using some other FlexNet license and license server
administration tool, such as FlexNet Manager. To use manual
notification, see Activating Tekla Structures licensing using manual
server notification.
To activate your licenses and notify the license server about license changes:
1.

Go to Tekla Structures Licensing --> Tekla Structures License
Administration Tool through the Start menu or Start screen, depending
on your Windows operating system.

2.

Enable the automatic license server notification functionality by clicking
the Notify Server button.

3.

You saved your entitlement certificate in the ..\TeklaStructures
\License\Server folder, and the licenses should now be listed in the
Entitled Licenses area. If they are not listed, click Open, select
EntitlementCertificate.html, and click Open again.

4.

Select the number of licenses to activate.

5.

Click the Activate button.
Your license server contacts the activation server at Trimble Solutions. The
activated licenses are displayed under the Activated Licenses area.

Next, you need to connect Tekla Structures to the license server when you
start Tekla Structures for the first time.
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Connect Tekla Structures to the license server
Connect Tekla Structures to the license server. This is phase 4 in the workflow
Taking Tekla Structures licenses into use (page 21).
To connect Tekla Structures to the license server when you start Tekla
Structures for the first time:
1.

Start Tekla Structures.

2.

To connect Tekla Structures to the license server, enter the
port@hostname information in the Connect to License Server dialog
box, for example 27007@HOST_NAME.
The host name and port must correspond with the host name and port
found in the tekla.lic file on the server computer located at ..
\TeklaStructures\License\Server. The license server administrator
informs users about the license server name and port number.

1. host
2. port
If there is more than one license server available with activated licenses,
you can define a primary and a secondary server in the Connect to
License Server dialog box by separating the servers with a semicolon as
follows: 27007@HOST_NAME_1;27007@HOST_NAME_2
Install and license Tekla Structures
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3.

Click OK to start Tekla Structures.

2.4 Borrowing licenses for using Tekla Structures offline
You can borrow an activated license from the license server when you work
offline and no license server is installed on your computer. The borrowed
license is transferred from the license server to your computer, so it is not
available for other users during the borrowing period.
To borrow licenses, follow the workflow below:
1.

Install and set up Tekla Structures License Borrow Tool for license
borrowing (page 25)

2.

Borrow a Tekla Structures license (page 26)

3.

Return a borrowed Tekla Structures license (page 26)

Install and set up Tekla Structures License Borrow Tool for
license borrowing
Set up Tekla Structures License Borrow Tool: install Tekla Structures
License Borrow Tool, connect Tekla Structures to the license server, and open
the product ID file containing all Tekla Structures configurations and their
product IDs. You may use the default product ID file (standard.tpi) or ask
your administrator to send you a new and customized product ID file that
contains only the configurations that you are allowed to use. This is phase 1 of
the workflow Borrowing licenses for using Tekla Structures offline (page 25).
To install and set up Tekla Structures License Borrow Tool:
1.

Download and install the latest Tekla Structures License Borrow Tool
from Tekla Downloads.
The installer is also available on the Tekla Structures installation DVD.

2.

Go to Tekla Structures License Borrow --> Tekla Structures License
Borrow Tool through the Start menu or Start screen, depending on your
Windows operating system.

3.

In the Borrow from License Server dialog box, enter the port number
with the host name (computer name) in format port@host in the Server
text box, for example, 27007@HOST_NAME.
You need to use exactly the same port and host name as in the Connect
to License Server dialog box when starting Tekla Structures.

4.

Click OK.
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5.

Click Open in Tekla Structures License Borrow Tool.

6.

Select the product ID file and click Open.
The list of licenses is updated in Tekla Structures License Borrow Tool.
Now you can borrow licenses.

Borrow a Tekla Structures license
Borrow a license from the Tekla Structures license server. This is phase 2 of the
workflow Borrowing licenses for using Tekla Structures offline (page 25).
To borrow a license from the license server:
1.

In Tekla Structures License Borrow Tool, in the Products area, click the
Borrow Until box and select the expiration date for the borrowing period
from the calendar.
The maximum borrowing period is one month.

2.

Click Borrow.
The borrowing progress is displayed. After successful borrowing the
Borrowed Licenses area shows the borrowed license.

3.

Disconnect your computer from the license server and start Tekla
Structures with the borrowed license to ensure that the borrowing
succeeded.

Return a borrowed Tekla Structures license
Return the borrowed license when you do not need to use it anymore. This is
phase 3 of the workflow Borrowing licenses for using Tekla Structures offline
(page 25).
A borrowed license is automatically available on the license server one day
after the expiration date. However, you need to return the expired license to
the license server to update the Borrowed Licenses area in Tekla Structures
License Borrow Tool. You can return a borrowed license any time.
To return a borrowed license:
1.

Connect your computer to the network where you can connect to the
license server.

2.

Close Tekla Structures.

3.

Go to Tekla Structures License Borrow --> Tekla Structures License
Borrow Tool through the Start menu or Start screen, depending on your
Windows operating system.
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4.

Select the Return check box in the Borrowed Licenses area to select the
license to return.

5.

Click Return.

After successful returning, the Borrowed Licenses area is updated.
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3

Start Tekla Structures

When you start Tekla Structures, you are asked to choose your Tekla Structures
setup. The setup consists of an environment, role, and configuration.
•

Environment means region-specific settings and information. It defines
which profiles, material grades, default values, connections, wizards,
variables, reports, and templates you have available.

•

Role is a user group profile that limits the availability of files and settings in
an environment. The user interface has been customized for each role.

•

Configuration consists of a set of features that the user is entitled to based
on the license agreement. Each configuration is meant for a specific user
group, to suit the various players in the construction industry.

1.

Start Tekla Structures by selecting it from the Windows Start menu or by
double-clicking the desktop icon.
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The Tekla Structures - Choose setup dialog box appears.

2.

Select an environment.
If you cannot find the desired environment from the list, see Install Tekla
Structures (page 20).
You can also select blank project (page 30) to create a model that
contains generic content, such as parametric profiles.

3.

Select a role.
The availability of roles depends on your environment, but typically the
following roles are available:

4.

•

All (a combination of all roles)

•

Concrete Contractor

•

Construction Management

•

Engineer

•

Precast Concrete Detailer

•

Rebar Detailer

•

Steel Detailer

Select a configuration.
The configuration you are using may not contain all the features described
in the Tekla Structures product guides. For more information on the
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features available in each configuration, see Tekla Structures
configurations (page 5).
5.

Click OK.
The Welcome page appears.

6.

Select what you want to do:
•

On the Recent tab, you can open a recently used model.

•

On the All models tab, you can open any existing model (page 35).

•

On the New tab, you can create a new model (page 36).

See also
Check or change your Tekla Structures setup (page 31)

3.1 What is a blank project
Blank project is a Tekla Structures environment that includes only generic
content, such as parametric profiles and undefined materials. It can be used
for gathering region-, company-, or project-specific settings, tools, and
information. The blank project is always included in the Tekla Structures
installation.
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Download and install content
You can use Tekla Warehouse to download and install content to the blank
project. For example, you can download profiles, material grades, bolts,
reinforcement, components, applications, and templates from Tekla
Warehouse across all environment- and manufacturer-specific collections, and
make combinations that suit your needs.
You can download and install content from Tekla Warehouse both before and
during a project. Before starting a project, you can install content to your
project and firm folders. During a project, you can install content to the model
folder.

3.2 Check or change your Tekla Structures setup
You can check your current Tekla Structures setup (environment, role, and
configuration) at any time without having to close the model.
1.

On the File menu, click Settings and scroll down to the License area.
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You current setup is displayed.

2.

Change the setup if needed.
You may be required to restart Tekla Structures after the changes.

3.3 Join or leave the Automatic User Feedback program
Join the Automatic User Feedback program to help improve Tekla Structures.
This is an easy way to influence the future development of Tekla Structures,
because the program collects anonymous information on how you use the
software.
The program collects usage patterns and trends of how you use the
commands and tools in the software. The program collects this information
automatically while you use Tekla Structures. You can view the log file to check
the collected data. Your privacy is always a priority - the information we collect
cannot be used to identify you, and your data is combined with other people's
data to make statistical analysis.
1.

On the File menu, click Settings and scroll down to the Automatic User
Feedback area.

2.

Select one of the options:

3.

•

Yes, I want to participate in the program: you accept the collecting
of anonymous information

•

No, I would not like to participate: you do not accept the collecting
of information

To check the data that has been collected, click the review the collected
data link.
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Tekla Structures displays the UserFeedbackLog.txt file.
4.

To send feedback or questions about the program, send e-mail to the
address tekla.usability@trimble.com.
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4

Open, create, and save 3D
models

With Tekla Structures, you can create information-rich 3D models of all
structures and materials. The model contains all the information that is
needed to manufacture and construct the structure: part geometry and
dimensions, profiles, materials, and so on.
•

Open a model (page 35)

•

Create a new model (page 36)

•

Save a model (page 40)

Model output
The 3D model is also the single source of information for drawings and other
outputs, such as reports and NC data files. This ensures that the information in
drawings and reports is always up to date, as they react to modifications in the
model.
Collaboration
You can use the multi-user mode or Tekla Model Sharing to work
collaboratively within a model.
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4.1 Open a model
You can have one model open at a time. If you open a model and already have
one open, Tekla Structures prompts you to save the first model.
1.

On the File menu, click Open.
•

To open a recently used model, click Recent.

•

To open any existing model, click All models.
If you want to search for models in another folder, click Browse.

•

To open a model that has been shared using Tekla Model Sharing, click
Browse shared models.

To sort models by name, date, or type, click the column titles.
When the models are sorted alphabetically by their names, you can use
the keyboard to select a model. For example, when you type N, Tekla
Structures selects the first model starting with an N.
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2.

Click Open.
If no views are visible in the model, Tekla Structures prompts you to select
one.

See also
Create a new model (page 36)
Create a thumbnail image of a model (page 36)

4.2 Create a new model
Create a separate model for each Tekla Structures project. Each model is
stored in its own folder under the TeklaStructuresModels folder.
1.

On the File menu, click New.

2.

In the Name box, enter a name for the new model.
Do not use special characters (/ \ ; : | ). We recommend that you try
to decide on a permanent name at this point. The name of the model can
be changed afterwards, but it involves changing several file names.

3.

Define where to save the new model.
By default, the model is saved in the TeklaStructuresModels folder
that was created during installation. You can change the default folder by
clicking Browse. You can also select a recently used folder from the Save
in list.

4.

If you want to use a model template, select one.

5.

Under Type, define whether to run Tekla Structures in single-user or
multi-user mode.

6.

•

Single-user: the model will be used by one person at a time.

•

Multi-user: the model is stored on a server and may be used by several
people simultaneously. Enter the name of the server in the Server box.

Click Create.
Tekla Structures creates the model and opens the default model view. The
contents of the model view may differ based on the model template you
chose in step 4.

See also
Create a thumbnail image of a model (page 36)
Edit project properties (page 37)
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4.3 Create a thumbnail image of a model
You can add a thumbnail image to make it easier to recognize your project
even when you do not remember the exact name of the model. The thumbnail
image is displayed when you browse for existing models.
1.

On the View tab, click

2.

Select a view.

Screenshot --> Project thumbnail.

Tekla Structures creates the image and saves it in the model folder with
the name thumbnail.png.
3.

To check the thumbnail, go to the File menu, click Open, and select the
model you created the thumbnail for.
The image is now displayed next to the model name. For example:

4.

If you are unhappy with the thumbnail image, you can repeat steps 1–2 as
many times as you need.
For example, you can zoom the model in and out to adjust what is shown
in the thumbnail image. When you create a new thumbnail, Tekla
Structures overrides the existing thumbnail image with the new one.

TIP Alternatively, if you want to use a custom image, you can add the image directly
to the model folder with the name thumbnail.png. The preferred size of the
image is 120 x 74 pixels.

4.4 Edit project properties
You will need project information, such as project number and name, many
times during a project. Update the project properties at the beginning of each
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project to make reports and drawings display the correct information
automatically. All of the fields are optional.
1.

On the File menu, click Project properties.

2.

Click

3.

In the Description box, enter a description that helps you identify the
model when you next need to open it.

4.

If you want to use another coordinate system for interoperability and
collaboration, click Base points to define a new base point.

Edit.

Once a base point has been defined, you can select it from the Location
by list.
5.

Edit the other project properties.

6.

To define project-specific user-defined attributes, click User-defined
attributes.
By default, you can define:
•

Project comment

•

User fields

•

Execution class

•

IFC export attributes

•

GEO coordinates

•

Status attributes

•

Unitechnic factory location

The availability of user-defined attributes depends on your environment
(page 28).
7.

Click Apply to save your changes.
Now you will get updated project properties in drawings and reports.

Displaying project information in templates and reports
The fields in the image below refer to template attributes, which you can use
when designing your own reports and templates. To display project
information, add the corresponding template attributes in the templates and
reports.
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(1) NUMBER#2
(2) NAME
(3) BUILDER
(4) OBJECT
(5) ADDRESS
(6) DESIGNER
(7) DATE_?START
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(8) DATE_?END
(9) INFO1, INFO2

4.5 Save a model
You should save your model regularly to avoid losing any work. Tekla
Structures also automatically saves your work at regular intervals.
NOTE Tekla Structures versions are not backwards compatible. When you save a
model, you cannot open it in older versions of Tekla Structures due to
database differences.

Save the current model

To save changes to the current model file, do one of the following:
•

On the top left corner of the screen, click Save

•

On the File menu, click Save as --> Save.

•

Press Ctrl+S.

.

Save a copy with different name or location

You can create a copy of the model with a different name or in a different
folder. The original version of the model remains intact.
NOTE When you save the model with a different name, all the GUIDs
(globally unique identifiers) of the saved model will change and be
different than in the original model. This means that the saved model
has no relation to the original model, and the saved model cannot be
used as backup.
1.

On the File menu, click Save as --> Save as.

2.

In the Model name box, enter a new name.

3.

To save in a different location, click Browse and define where you want to
save the model.

4.

Click OK.
Tekla Structures creates a new copy with a different name, but the original
version of the model remains intact.
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Save a backup copy

You can create a backup copy of the model with the same GUIDs (globally
unique identifiers) as the original model.
1.

On the File menu, click Save as --> Save and create backup copy.
Tekla Structures saves a copy of the model in the ..
\TeklaStructuresModels\backup\<model_name>\<date-time>
folder.

2.

If you need to take the backup copy into use in place of the current model,
move the backup copy from the chosen date to your model folder.
You can either replace all contents of the current model folder with the
content of the chosen backup folder, or you can rename the backup
folder (<date-time>) to match the original model name.

3.

If you want to change the location of the backup folder, use the advanced
option XS_MODEL_BACKUP_DIRECTORY.

NOTE To save disk space, you can compress the
XS_MODEL_BACKUP_DIRECTORY folder.

Save as a model template
See Create model templates.

Define autosave settings

Use Autosave to automatically back up and save your work at set intervals.
You can set the autosave interval separately for the model and drawings.
Autosave files have the extension .db1_<user>.
1.

On the File menu, click Settings --> Options, and go to the General
settings.

2.

Under Autosave, set the autosave interval.
a.

In the first box, define how often Tekla Structures saves the model or
drawing.
This number represents the number of commands you will have to
run before Tekla Structures saves the model or drawing. For example,
if you create many steel beams without interrupting the Create steel
beam command, it only counts as one command.

b.

In the second box, enter the number of drawings after which Tekla
Structures saves your work.

NOTE If you set the interval values to less than 2, autosave is disabled.
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3.

Click OK.

4.

Define where to store the Autosave files.
By default, Tekla Structures stores the autosave files in the ..
\TeklaStructuresModels\autosave folder. To change the folder, use
the advanced option XS_AUTOSAVE_DIRECTORY.

5.

Define whether to keep old autosave files.
By default, Tekla Structures deletes the autosave files when you close a
model, to save disk space. To keep autosave files even if you exit Tekla
Structures without saving the model, use the advanced option
XS_KEEP_AUTOSAVE_FILES_ON_EXIT_WHEN_NOT_SAVING.
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5

Get familiar with the user
interface

When you open a Tekla Structures model, a new window appears. By default,
the user interface will look something like this:

(1) This is your Tekla Structures model. If you are starting a completely new
project, you will only see the default model view and an empty grid at this
point.
(2) The green cube symbol represents the global coordinate system and it lies
at the global origin (x=0, y=0, z=0).
(3) The box around the grid represents the work area. In a view, you can only
see the parts that are within this area. Objects that are outside the work area
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exist in the model, but they are not visible. You can shrink and expand the
work area to suit your needs. You can also hide the work area box.
(4) The coordinate symbol with the three axes x, y, and z represents the local
coordinate system. It also indicates the direction of the model.
(5) The File menu is where you manage your models. You can save models
(page 40), print drawings, and import and export models, among other things.
(6) The ribbon contains all the commands and other functions you will use
when building your model. You can customize the ribbon according to your
needs.
(7) By default, the Quick Access Toolbar contains the Save, Undo, Redo, and
Undo history shortcuts icons.
(8) If you cannot find the command or dialog box you are looking for, search
with Quick Launch (page 59).
(9) Use the side pane (page 60) on the right side of the screen to view model
objects properties, add reference models and components, attach point
clouds, use custom inquiry, or to find direct access to Tekla Online services.
(10) The selection switches control which objects you can select.
(11) The snap switches control which positions you can pick when creating
objects.
(12) When you create objects, the status bar (page 68) will tell you how to
proceed and when to pick points.

5.1 How to use the ribbon and the commands on the
ribbon
All the essential commands in Tekla Structures are available on the ribbon. The
commands are grouped according to their use. You can modify the
appearance of the ribbon, and customize the content of the ribbon, if needed.
All commands throughout Tekla Structures work in the same manner.

How to use commands on the ribbon
To

Do this

Find commands
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mouse, or scroll with your mouse
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How to use the ribbon and the commands on the
ribbon

To

Do this
Some commands have more options
under them. The options become
available when you click the
command's name:

Activate the command you want to
use
Check which command you need for
your current task, if you are unsure

On the ribbon, click the command.
The command runs until you end it or
use another command.
Rest the mouse pointer on a
command.
A small window called tooltip
appears. Tooltips provide more
information about commands and
also give examples, hints, and tips.
For example:

Find more help on the command

Press Ctrl+F1 when a tooltip is open.
To switch the tooltips on or off, click
File menu --> Settings --> Switches,
and then select or clear the Tooltips
check box.

End command

Right-click and select Interrupt.
You can also press Esc.

Re-activate the last command
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Press Enter.

How to use the ribbon and the commands on the
ribbon

Change the appearance of the ribbon

You can change the order of ribbon tabs, choose how they are aligned, and
even hide some parts of the ribbon if you do not need them in your current
project. For example, if you are only modeling steel parts, you can temporarily
hide the Concrete tab.
To

Do this

Change the order of tabs on the
ribbon

Drag and drop the tab titles.

Change how the tabs are aligned

Right-click on the top bar of the
ribbon, select Navigation mode, and
then select one of the options.
•

Scroll visible: the ribbon
movement is minimal when you
switch between the tabs

•

Align to left: the icons start from
the left side of the ribbon

•

Align to tab: the icons start from
the left side of the current tab

Hide the tabs that you do not need in 1.
your current project

Rest the mouse pointer on a tab
title.
A small eye symbol appears next
to the tab title:

2.

Click the eye symbol

.

The eye symbol changes and the
tab title becomes gray:

The View tab is now hidden from
the ribbon. If you slide the
ribbon, hidden tabs appear as:

3.
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To re-display the hidden tab, click
the eye symbol again.

How to use the ribbon and the commands on the
ribbon

Minimize the ribbon

You can minimize the ribbon to save space on your screen. When the ribbon is
minimized, the command buttons are hidden but the tabs are visible.
1.

Right-click on the top bar of the ribbon, and select Minimized.

The ribbon is now minimized to save space on the screen:

2.

To access the commands when the ribbon is minimized, click a tab title.
The ribbon becomes visible so that you can select a command.

3.

To restore the ribbon, right-click on the top bar of the ribbon, and select
Minimized again.

See also
Customize the ribbon (page 47)

5.2 Customize the ribbon
You can customize the ribbon according to your needs. You can change the
size and shape of any command button, for example. You can add custom
buttons and assign commands to them. You can also bring your favorite
components and extensions to the ribbon for an easy access.
Company administrators can distribute the customized ribbons with the whole
organization, in the same way as customized property pane layouts or
customized tabs.
To open the customization tool, click File menu --> Settings --> Customize -->
Ribbon.
The tool includes two editing modes:
•

Simple mode: Add, move, and resize command buttons; add, hide, and
edit tabs; remove command buttons and tabs from the ribbon.
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•

Design mode: Choose which name and icon is used for each command
button; add new buttons and assign commands to them; add vertical and
horizontal separator bars.

Add a command button

You can add command buttons simply by dragging commands to the ribbon or
to the Quick Access Toolbar.
1.

Ensure that Simple mode is switched on.

2.

In the Select ribbon list, select which ribbon you want to customize.
For example:

You can only customize ribbons that are available in your configuration.
3.

Search for the command you want to add.
You can also add components, macros, and extensions. Browse through
the lists or use the Search box to filter content. For example, type mesh to
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find the Create reinforcement mesh command and other mesh related
components:

4.

•

User-defined: commands that you have created on the User-defined
commands tab

•

Tekla Structures: all the Tekla Structures commands available in this
configuration and mode

•

Applications & components: components, macros, plugins, and
extensions

Drag and drop the command to the ribbon.
The blue color indicates the place where the command button will be
inserted. For example:

NOTE If you hover over a down arrow, a list will open and you can drag
commands to the list. The list will remain open until you click the
down arrow again.
You can also drag commands to the Quick Access Toolbar, which is
located above the ribbon, or to the fixed container on the left side of the
ribbon:
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Remove a command button
1.

Select the command button.

2.

Press Delete on your keyboard.

Move a command button

You can rearrange command buttons on the ribbon. Note that you cannot
move drop-down buttons underneath each other.
1.

Select the command button you want to move.
The command button becomes highlighted:

2.

Drag and drop the command button to a new location.
The blue color indicates the place where the command button will be
inserted. For example:

Resize a command button

You can change the size of existing command buttons.
1.

Select the command button you want to resize:
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2.

Move the mouse pointer over any side or corner of the command button
to display a white arrow symbol:

3.

Drag with the arrow to define a new size:

The size of the command button changes accordingly. The other
command buttons are automatically moved forward on the ribbon, if
needed.

4.

Double-click the command button to expand it.
The command button now fully occupies the empty space around it:

Change the appearance of a command button

You can change the appearance of any command button in the Design mode.
1.

Ensure that Design mode is switched on.

2.

Select the command button you want to modify.
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The current properties of the command button are displayed.

3.

4.

To change the name, select one of the options:
•

None: no name is used for the command button

•

Short name: the default short version of the name is used

•

Full name: the default full version of the name is used

•

Custom: enter a custom name for the command button

To change the icon, select one of the options:
a.

None: no icon is used for the command button

b.

Large icon: the default large icon (32x32) is used

c.

Small icon: the default small icon (16x16) is used

d.

Gallery: select an icon from the Tekla Structures icon gallery

e.

Custom: define a custom icon by selecting a suitable image file. The
recommended size is 32x32 pixels for large buttons and 16x16 pixels
for small buttons. If you have problems with your custom image not
appearing the right size, check the DPI setting of the image file. A DPI
of 96 is recommended.

TIP When you modify a command button which is on a drop-down list, the options
may become hidden behind the drop-down list. Slide the ribbon right or left to
make the options visible.

Create a user-defined command

You can create user-defined commands and link them to any file or URL.
1.

Go to the User-defined commands tab.

2.

Click Add.

3.

Enter a unique ID for the command, and then click Create.
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For example, let's assume you are creating a link to the Tekla Discussion
Forum. Enter OpenTeklaDiscussionForum as the ID of the command.
A new page with more properties appears.

4.

Click Action and define a file or URL. For example, enter https://
forum.tekla.com.

5.

Click Name and enter a name for the command. This name will be visible
in the Tekla Structures user interface. You can define two alternative
names: a full name and a short version. For example, enter Tekla
Discussion Forum as the full name of the command, and Forum as the
short version.

6.

Click Icon and select a suitable icon from the Tekla Structures icon gallery.
You can define two alternative icons: a large one and a small one.

7.

Click Tooltip and enter a tooltip for the command. For example, enter Go
to the Tekla discussion forum.

8.

Click Apply to save the new command.

9.

Go to the Edit ribbons tab.
The command you created is available in the User-defined list, on the lefthand side of the dialog box:

10. Drag and drop the command to the ribbon:
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11. To modify a user-defined command, switch to the Design mode and edit
the command properties just like for any other command.

Add a custom button and assign a command to it

You can add new buttons, split buttons, toggle buttons, and drop-down
buttons to the ribbon. These are all empty placeholders for commands. After
creating a new button, you can assign a command to it.
1.

Ensure that Design mode is switched on.

2.

On the Edit ribbons tab, click the desired button type to select it:

•

Basic: Add a button for a single command.

•

Toggle: Add a toggle button that switches a particular command on or
off. Use this to add any switch from the File menu --> Settings -->
Switches to the ribbon, for example.

•

Drop-down: Add a drop-down button with a group of commands
underneath it. You can define a name and a custom tooltip for the
button.

•

Split: Add a button for a single command, plus a drop-down button
with a group of commands underneath it.

3.

Using the mouse, draw a rectangular area for the new button.

4.

To assign a command to the button:
a.

Ensure that the new button is selected.
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b.

On the Command tab, search for the command you want to add.
Browse through the lists or use the Search box to filter content. For
example:

5.

c.

Click Assign this command. The command is now assigned to the
button.

d.

On the Appearance tab, modify the command's name and icon, if
needed.

To add commands to a drop-down button:
a.

Return to the Simple mode.

b.

Search for commands.

c.

Drag and drop commands to the drop-down button.
If you hover over a down arrow, a list will open and you can drag
commands to the list. The list will remain open until you click the
down arrow again.
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Add a separator bar

You can add vertical and horizontal separator bars to divide command buttons
into smaller groups on the ribbon.
1.

Ensure that Design mode is switched on.

2.

Click Separator to select it.

3.

Using the mouse, draw a rectangular area in the vertical direction.

A vertical bar appears in the location you defined.
4.

Ensure that the bar is selected.

5.

Modify the orientation and line thickness of the bar, if needed.

Add, hide, and edit tabs

You can add, move and rename ribbon tabs, choose how they are aligned, and
hide some tabs if you do not need them in your current project. For example,
if you are only modeling steel parts, you can temporarily hide the Concrete
tab.
1.

Ensure that Simple mode is switched on.

2.

To add a new tab, click the plus sign

3.

To rename a tab:

at the end of the tab row.

a.

Right-click a tab title and select Rename....

b.

Type a new name.

c.

Press Enter to save the new name.

4.

To change the order of tabs on the ribbon, drag and drop the tab titles.

5.

To change how the tabs are aligned, click
options:
•

and then select one of the

Scroll visible: the ribbon movement is minimal when you switch
between the tabs
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6.

•

Align to left: the icons start from the left side of the ribbon

•

Align to tab: the icons start from the left side of the current tab

To hide the tabs that you do not need in your current project:
a.

Rest the mouse pointer on a tab title.
A small eye symbol appears next to the tab title:

b.

Click the eye symbol

.

The eye symbol changes and the tab title becomes gray:

The View tab is now hidden from the ribbon. If you slide the ribbon,
hidden tabs appear as:

c.
7.

To re-display the hidden tab, click the eye symbol again.

To remove a tab, select it and press Delete.

Save the ribbon

When you are happy with the changes, save the customized ribbon.
.

1.

On the Edit ribbons tab, click the Save button

2.

When you return to Tekla Structures and the program asks if you wish to
load the new ribbon, click Yes. The ribbon becomes updated with the
changes you made.

Check the changes

You can compare the original ribbon with the changes you have made. You can
check what has been added and removed, and what has been moved to
different tabs.
1.

Save the customized ribbon, if you have not already done so.
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2.

Click Compare.

3.

In the Compare ribbons dialog box, check the changes you have made.
For example:

•

First list: these commands have been removed

•

Second list: these commands have been moved to a new place

•

Third list: these commands have been added

NOTE Original ribbon refers to the ribbon file that came with theTekla
Structures installation for your current configuration.
4.

If you have removed a command that you would like to get back, drag it
from the Compare ribbons dialog box to the ribbon.

5.

When you are finished, click Close.

Back up and restore ribbons

You can restore the default Tekla Structures ribbons at any time. Before
restoring the default settings, make sure to save a backup copy of your
customized ribbon, because the customizations will be permanently deleted.
You can use the backup file to take your customized ribbon back into use, to
copy the ribbon settings to another computer, or to share the customized
ribbon with your co-workers.
1.

To save a backup copy of the customized ribbon:
a.

On the Edit ribbons tab, click the Save button
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.

b.

Go to the ..\Users\<user>\AppData\Local\Trimble
\TeklaStructures\<version>\UI\Ribbons folder.

c.

Make a copy of the desired ribbon file and save it in another folder.
The ribbons are named according to the Tekla Structures
configurations. For example, in the Full configuration, the name of
the Modeling ribbon file is albl_up_Full--main_menu.xml.

2.

To restore the default Tekla Structures ribbons:
a.

In the Select ribbon list, select which ribbon you want to restore.
For example:

b.
3.

Click Reset to defaults. The default Tekla Structures ribbons are now
in use.

To take the customized ribbon back into use:
a.

Copy the backup file back to the ..\Users\<user>\AppData
\Local\Trimble\TeklaStructures\<version>\UI\Ribbons
folder.

b.

When you return to Tekla Structures and the program asks if you wish
to load the new ribbon, click Yes. The ribbon becomes updated with
the changes you made.

5.3 How to use Quick Launch to find commands, dialog
boxes, and toolbars
Use the Quick Launch box in the upper-right corner of the screen to find
commands, dialog boxes, toolbars, and other functions. The shortcut key for
Quick Launch is Ctrl+Q.

1.

In the Quick Launch box, enter a search term. For example, type bolt if
you are looking for bolt commands.

2.

Wait for a list of search results to appear. For example:
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How to use Quick Launch to find commands,
dialog boxes, and toolbars

Tekla Structures highlights the commands on the ribbon or on the File
menu, to help you locate them. For example:

3.

To run a command, click its name on the search results list.
Or press Enter to instantly run the first command on the list.
For some basic settings (page 68) and toolbars a check box appears in
front them in the search results list. Click the command to activate the
setting, or to have the toolbar visible.

TIP If the list of search results is no longer visible, press Ctrl+Space to
reactivate it.
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5.4 How to use the side pane
Use the side pane on the right side of the screen, for example, to view model
object properties, and to add reference models and components.
To

Do this

Open a side pane window

Click a side pane button to open a side pane
window.
•
Click
to view model object properties
using Custom inquiry.
•

Click
to find shortcut access to the
different Tekla Online services.

•
Click
model.

to attach point clouds to a

Click
objects.

to show the properties of model

Click
list.

to show the reference models

•

•

•

to show the Applications &
Click
components catalog.

When you click a side pane button, the side
pane window opens and becomes active.
Active side pane windows have yellow
buttons
Close a side pane window

You can close one active side pane window at
a time, or several windows at one go.
•

Click an active side pane button to close a
single side pane window.

•

Click Ctrl+active side pane button to
close all the other side pane windows
expect the selected side pane.

•
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Click the
window.

button in the side pane

How to use the side pane

To

Do this

Open or close active side
pane windows

Active side pane windows have yellow
buttons

.

Click the arrow
in the side pane to open
or close the active side pane windows at one
go.
Keep multiple side pane
windows open at the same
time

You can have several side pane windows open
at the same time.
•

Click the side pane buttons to open as
many side pane windows as needed. The
active side pane windows are stacked on
top of each other.
You can resize the side pane windows and
change their order by dragging them.

•

Move a side pane window

Alternatively, right-click a side pane button
and select Open below. Repeat for each
side pane button.

When you position the mouse pointer on the
upper part of the side pane window, the
upper part is shown in yellow.
Grab the yellow upper part of the side pane
window and drag the window to a new
location.

Float and dock a side pane
window

You can float or dock side pane windows.
•

To float a side pane window: right-click a
side pane button and select Float.

•

To dock a side pane window: right-click an
active side pane button and select Attach
to side pane.
Alternatively, you can drag the side pane
window back to the docking area on the
right or at the bottom of the screen. The
docking area is marked with yellow color.
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To

Do this

If you float a side pane window and close
Tekla Structures, the side pane window will be
opened in its floating position when you start
Tekla Structures the next time.
Adjust the size of a side pane
window

Resize a floating side pane window by
dragging its borders.

Find more help on the
content of a side pane
window

Click the

button.

TIP Sometimes a side pane window opens on a second display that is not
connected to your computer at the moment. To return the side pane
window to the main display, right-click the side pane button and select
Attach to side pane
See also
Get familiar with the user interface (page 43)

5.5 How to use the contextual toolbar
When you click an object in a model or drawing, a contextual toolbar symbol
appears next to the mouse pointer. Click the symbol to open the
contextual toolbar. Use the contextual toolbar to quickly view and change
some basic properties of an object, view, grid, and so on.

If multiple objects are being selected, the contextual toolbar displays the text
Varies for any properties that differ.
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How to change object properties using contextual toolbar

The changes that you make on the contextual toolbar are immediately applied
to the model or drawing.
1.

Click an object in a model or drawing.
A contextual toolbar appears next to the mouse pointer.

2.

Change the object properties on the contextual toolbar.
The changes are applied immediately.

TIP Press the Tab key to move between the properties and command buttons on the
contextual toolbar.

Show or hide contextual toolbar

You can define whether the contextual toolbar is visible in Tekla Structures.
1.

On the File menu, click Settings.

2.

Under Switches, select or clear the Contextual toolbar check box.
Alternatively, use the keyboard shortcut Ctrl+K to show or hide the
contextual toolbar.

Define contextual toolbar's position

You can define the position of the contextual toolbar, relative to an object's
reference point.
1.

Select an object.

2.

Hold down the Ctrl key and click the contextual toolbar with the left
mouse button.
A dashed line appears between the contextual toolbar and the object.

3.

Drag the contextual toolbar to a new position. For example, you can
position the contextual toolbar on the left side of the selected object.

4.

Release the left mouse button. The contextual toolbar now appears in the
position you defined, for example on the left side of any object you select.

Get familiar with the user interface

64

How to use the contextual toolbar

Pin contextual toolbar in place

You can pin the contextual toolbar to a specific location on the screen, so that
the position is locked. For example, you could have it appear at the upper left
corner of the screen. In the locked state, the position of the contextual toolbar
is independent of the individual part’s location.
1.

Drag the contextual toolbar to a new location.

2.

Click

to pin the contextual toolbar to the new location.

The pin icon changes when the position is locked.
3.

To unlock the position, click

.

Minimize contextual toolbar

You can minimize the contextual toolbar so that it takes less space on your
screen.
1.

On the contextual toolbar, click
symbol

2.

. The contextual toolbar now has the

.

To restore the contextual toolbar to its original size, click

again.

See also
Customize the contextual toolbar (page 65)

5.6 Customize the contextual toolbar
You can customize the contextual toolbar by selecting which toolbar elements
are visible. You can also adjust the width of the elements, and add icons and
additional titles to the elements.

Customize contextual toolbar
1.

On the contextual toolbar, click

2.

Select and clear check boxes to define which toolbar elements you wish to
show or hide.
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The Preview area shows what the toolbar will look like. For example:

3.

To modify the toolbar elements:
a.

Click the toolbar element.
If the element can be modified, the following box appears:

4.

b.

Use the slider to adjust the width of the toolbar element.

c.

To add an additional title, click the text box and enter a title.

d.

To add an icon, click

e.

To remove the icon or title, click

and select an icon from the list.
.

To add macros and user-defined attributes:
a.

Select the desired macro or user-defined attribute from the list.

b.

Click Add.
Tekla Structures adds the macro or user-defined attribute to the list
of toolbar elements and to the Preview image. For example:

c.

To hide the macro or user-defined attribute, clear the corresponding
check box as described in step 2.
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5.

Click OK to save the changes.

Create user profiles for contextual toolbars

You can create multiple profiles for contextual toolbars. Each profile contains
the same contextual toolbars, but with different settings.
1.

On the contextual toolbar, click

2.

Click Set profiles.

3.

Select New profile from the list.

4.

Enter a name for the profile.

5.

Click Save.

6.

Customize the contextual toolbar.

.

For example, remove some elements from the contextual toolbar.
7.

Click OK to save the changes.
The user profile is now active with the settings you defined.

8.

To switch to another profile:
a.

Click Set profiles.

b.

Select another profile from the list.

c.

Modify the settings.

d.

Click OK.
This user profile is now active.

Back up and share contextual toolbars

We advice you to save a backup copy of your customized contextual toolbars.
You can use the backup file to copy settings to another computer or to share
the customizations with your co-workers.
1.

Save the contextual toolbar under a user profile, with a name that you can
easily recognize. For example, MyContextualToolbar.

2.

Go to the ..\Users\<user>\AppData\Local\Trimble
\TeklaStructures\<version>\ContextualToolbar\Profiles
folder.

3.

Make a copy of your customized contextual toolbar and save it in the
corresponding folder on another computer.

4.

To open a customized contextual toolbar on another computer:
a.

On the contextual toolbar, click

b.

Click Set profiles.
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c.

Select the correct profile from the list. For example,
MyContextualToolbar, if that is the name you used in step 1.

d.

Click OK. The customizations are now active.

NOTE Alternatively, you can place the entire ContextualToolbar folder to
your company's firm folder or in the system folder, which is located
under your environment folder: ..\ProgramData\Tekla
Structures\<version>\Environments\<environment>\system.

5.7 View status bar messages
Status bar is the area located at the bottom of the Tekla Structures main
window. Follow the instructions on the status bar when you use commands.
For example, when you are creating a part, the status bar will tell you how to
proceed and when to pick points.

1.

Instructions and error messages

2.

The status of Smart select (S), Drag & drop (D), and Ortho (O)

3.

The level in assembly or component hierarchy (0–9)

4.

The middle mouse button mode (Pan or Scroll)

5.

The current phase

6.

The number of selected objects and handles
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5.8 Basic settings in the File menu
Use the switches in File menu --> Settings --> Switches to control some basic
modeling and drawing settings.
Alternatively, you can control the switches with Quick Launch. Start typing the
name of the switch, for example, smart, and click the name of the switch on
the search results list to activate the switch.
Option

Description

Smart select

Change how drag-and-drop works for
object handles.
When the option is on, you can drag
from object handles without selecting
them first.
When the option is off, you must
select the handles before dragging.

Drag & drop

Activate or inactivate the drag-anddrop command.
When the option is on, you can use
drag-and-drop when copying or
moving objects.
When the option is off, drag-and-drop
cannot be used.

Middle button pan

Change the panning mode.
When the option is on, you can move
the model using the middle mouse
button.
When the option is off, you can move
the model using the left mouse
button.

Centered zooms

Change the zooming mode.
When the option is on, the center
point of zooming is kept in the middle
of the view, regardless of the mouse
pointer position.
When the option is off, the mouse
pointer position determines the
center point of zooming.

Basic view auto rotation

Activate or inactivate the auto
rotation of part and component 3D
views.
When the option is on, Tekla
Structures rotates the view once
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Option

Description
whenever you create a new 3D view
of a part or component.
When the option is off, Tekla
Structures does not rotate the view.

Crossing selection

Change how area selection works.
When the option is on, all objects that
fall at least partially inside the
rectangular area are selected,
regardless of the dragging direction.
When the option is off, the dragging
direction affects the selection of
objects.

Rollover highlight

Switch the highlighting of objects on
or off.
When the option is on, Tekla
Structures highlights selectable
objects in yellow when you move the
mouse pointer on them.
When the option is off, selectable
objects are not highlighted.

Select on right-click

Change how objects can be selected.
When the option is on, you can select
objects also with the right mouse
button. Also the related shortcut
menu is displayed immediately.
When the option is off, you can select
objects with the left mouse button.

Automatic rotation center

Define how the view point is set.
When the option is on, the view point
changes whenever you click the
middle mouse button.
When the option is off, the view point
stays in a set position.

Ortho

Activate or inactivate orthogonal
snapping.
When the option is on, Tekla
Structures snaps to the closest
orthogonal point on the plane (0, 45,
90, 135, 180 degrees, and so on). The
mouse pointer automatically snaps to
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Option

Description
positions at even distances in the
given direction.
When the option is off, orthogonal
snapping is not used.

DirectX rendering

Switch between OpenGL rendering
and DirectX rendering.
When the option is on, DirectX
rendering is used.
When the option is off, OpenGL
rendering is used.

Contextual toolbar

Show or hide the contextual toolbar
(page 63).
When the option is on, the contextual
toolbar appears when you select
objects.
When the option is off, the contextual
toolbar does not appear.

Tooltips

Show or hide the tooltips (page 44).
When the option is on, a small
window with examples, hints, and tips
appears when you rest the mouse
pointer on a command.
When the option is off, no tooltips
appear.

The following settings are available only in drawings:
Option

Description

Printer line widths

Show the lines in color drawings with
defined thickness on the screen.
When the option is on, the lines in
color drawings are shown with
defined thickness.
When the option is off, the lines in
color drawings are shown with default
thickness.

Ghost outline
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ghost outlines in color drawings. In
grayscale and black and white
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Option

Description
When the option is on, hidden lines
are shown as ghost outlines.
When the option is off, hidden lines
are not shown.

Associativity symbol

Shows which drawing objects are
associative and automatically
updated. Associativity symbols are
shown only when you select a
drawing object, for example a
dimension.
Objects that do not have valid
association get a ghost associativity
symbol and a question mark.
When the option is on, associativity
symbols are shown.
When the option is off, associativity
symbols are not shown.

5.9 Icons on the Quick Access Toolbar
Quick Access Toolbar provides shortcut icons to the commonly used
commands. The toolbar is located on top left corner of the screen.
If needed, you can customize (page 47) the Quick Access Toolbar and add the
commands of your choice to it.
Icon

Description
Save (page 40) changes to the current model file.
Undo the last action.
Redo the actions previously undone.
Open the Undo history dialog box. The dialog box
lists the commands you have run and the
modifications you have done. Use the list to undo or
redo several commands or modifications at one go.
To undo commands, click any row on the list. All the
modifications you have done after the selected
command are undone. The modifications you have
undone have a dark gray background color in the list.
To redo previously undone commands, click any row
with a dark gray background color in the list. The
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Icon

Description
modifications you have done before the selected
command are redone.
to mark important commands or
Add bookmarks
actions. You can later return to these commands or
actions if the changes in the model are not
satisfactory.
The undo and redo actions create a hierarchy in the
list. The hierarchy is marked with an arrow. You can
undo or redo commands at any point in the hierarchy.
The list is cleared when you
•

save a model

•

open or close a drawing

•

synchronize Organizer with the model

•

read in or write out model changes using Tekla
Model Sharing

•

use CIS/2 or SDNF import commands.

This icon is visible if you use Tekla Model Sharing.
Read in other users' model changes from the sharing
service. Only the changed data is read in.
This icon is visible if you use Tekla Model Sharing.
Write out your model changes to the sharing service.
Only new or changed data is written out.
The icon is visible if you use Tekla Model Sharing.
Show read in changes. After you have read in, a list of
model changes is displayed.
See also
Get familiar with the user interface (page 43)

5.10 Default keyboard shortcuts
Tekla Structures contains a large number of keyboard shortcuts that you can
use to speed up your work.
If you want to change the default shortcuts, see Customize the keyboard
shortcuts (page 77).
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Common commands
Command

Keyboard shortcut

Help

F1

Help: when tooltip is open

Ctrl+F1

Open model

Ctrl+O

Create new model

Ctrl+N

Save model

Ctrl+S

Delete

Del

Properties

Alt+Enter

Undo

Ctrl+Z

Redo

Ctrl+Y

Interrupt

Esc

Repeat last command

Enter

Show/hide contextual toolbar

Ctrl+K

Switch direct modification on/off

Ctrl+D

Quick Launch

Ctrl+Q

Advanced options

Ctrl+E

Applications & components catalog

Ctrl+F

Rendering options
Command

Keyboard shortcut

Parts wireframe

Ctrl+1

Parts shaded wireframe

Ctrl+2

Parts grayscale

Ctrl+3

Parts rendered

Ctrl+4

Show only selected part

Ctrl+5

Components wireframe

Shift+1

Components shaded wireframe

Shift+2

Components grayscale

Shift+3

Components rendered

Shift+4

Show only selected component

Shift+5
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Selecting objects
Command

Keyboard shortcut

Rollover highlight on/off

H

Select all selection switch

F2

Select parts selection switch

F3

Select all

Ctrl+A

Select previous objects

Alt+P

Select assembly

Alt+object

Add to selection

Shift

Toggle selection

Ctrl

Selection filters

Ctrl+G

Hide object

Shift+H

Snapping
Command

Keyboard shortcut

Snap to reference lines/points

F4

Snap to geometry lines/points

F5

Snap to nearest points

F6

Snap to any position

F7

Ortho

O

Relative coordinate input

R

Absolute coordinate input

A

Global coordinate input

G

Snap to next position

Tab

Snap to previous position

Shift+Tab

Lock X, Y or Z coordinates

X, Y or Z

Copying and moving objects
Command

Keyboard shortcut

Copy

Ctrl+C

Move

Ctrl+M

Drag and drop

D

Smart Select

S
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Viewing the model
Command

Keyboard shortcut

Open the view list

Ctrl+I

3D/Plane view

Ctrl+P

Switch between views

Ctrl+Tab

Updated window

Ctrl+U

Zoom original

Home

Zoom previous

End

Zoom in

Page Up

Zoom out

Page Down

Rotate using mouse

Ctrl+R

Rotate using keyboard

Ctrl+arrow keys
Shift+arrow keys

Set view rotation point

V

Rotate once

Shift+R

Rotate continuously

Shift+T

Pan

P

Middle button pan

Shift+M

Move right

arrow keys

Move left
Move down
Move up
Fly

Shift+F

Create clip plane

Shift+X

Checking the model
Command

Keyboard shortcut

Inquire object

Shift+I

Measure distance

F

Create report

Ctrl+B
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Drawings
Command

Keyboard shortcut

Open Drawing list in model

Ctrl+L

Open Drawing list in drawing mode

Ctrl+O

Print drawings

Shift+P

Open next drawing

Ctrl+Page Down

Open previous drawing

Ctrl+Page Up

Associativity symbol

Shift+A

Set next drawing color mode

B

Ghost outline

Shift+G

Add orthogonal dimension

G

Add free dimension

F

Open any drawing after creating the
drawing

Ctrl+Shift

In Drawing list: Open user-defined
attributes

Alt+U

In Drawing list: Add to Master
Drawing Catalog

Ctrl+M

In Drawing list: Revision handling

Ctrl+R

In Master Drawing Catalog: Select all Ctrl+A
In Master Drawing Catalog: Create
drawings for all parts

Alt+A

In Master Drawing Catalog: Create
drawings

Alt+C

Set UCS origin

U

Set UCS by two points

Shift+U

Toggle orientation

Ctrl+T

Reset current

Ctrl+1

Reset all

Ctrl+0

5.11 Customize the keyboard shortcuts
In the Keyboard shortcuts dialog box, you can view a list of all shortcuts
available in Tekla Structures. You can define new keyboard shortcuts and
remove existing ones. After customization, you can export the keyboard
shortcuts and share them with your co-workers.
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Define new keyboard shortcuts

You can assign keyboard shortcuts to any command, macro, or component.
You can even change the default keyboard shortcuts, if needed.
1.

On the File menu, click Settings --> Keyboard shortcuts.
The Keyboard shortcuts dialog box opens.

2.

In the Group list, select the shortcut group you want to modify.
A list of commands and shortcuts appears.

3.

If you want to search for a particular command or keyboard shortcut,
enter some text in the Filter box.
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For example:
•

Type grid to only see the commands whose name contains the word
"grid".

•

Type "+" to get a list of shortcuts that consist of two parts (such as Ctrl
+S).

•

Type "," to get a list of shortcuts that consist of two consecutive keys
(such as M, N).

4.

Select a command from the list.

5.

Click Enter shortcut.

6.

On the keyboard, enter the combination of keys you would like to use as
the shortcut.

7.

Check the Conflicts box to see if the keyboard shortcut is already
assigned to another command.
If the shortcut is already in use, enter a different combination of keys.
NOTE If you reassign a keyboard shortcut that is already used, it will no
longer be associated with the command it was originally assigned
to.

8.

Click Assign to save the keyboard shortcut.

Clear and reset shortcuts

You can remove any existing shortcut. You can also reset all shortcuts back to
the defaults.
1.

On the File menu, click Settings --> Keyboard shortcuts.

2.

To remove a keyboard shortcut, select the command from the list and click
Clear.

3.

To reset all the keyboard shortcuts to the defaults (page 73), click the
Restore button.

Export keyboard shortcuts

You can export your customized keyboard shortcuts and share them with your
co-workers.
1.

On the File menu, click Settings --> Keyboard shortcuts.

2.

Click Export.

3.

Enter a file name and location.

4.

Click Save to export the keyboard shortcuts.
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5.

To share your keyboard shortcuts with other users, send them the
exported file.

Import keyboard shortcuts

You can import keyboard shortcuts from a file. Use this method to import
keyboard shortcuts from Tekla Structures 2016 or newer.
1.

On the File menu, click Settings --> Keyboard shortcuts.

2.

Click Import.

3.

Browse for the shortcuts file you want to import. For example, ..\Users
\<user>\AppData\Local\Trimble\TeklaStructures
\2016\Settings\KeyboardShortcuts_4.xml.

4.

Click Open to import the keyboard shortcuts.

5.12 Learn the common buttons
The following table lists some common buttons that can be found in the Tekla
Structures dialog boxes.
Button

Description
Saves the properties and closes the dialog box. Tekla
Structures uses these properties the next time you create an
object of this type.
Saves the properties without closing the dialog box. Tekla
Structures uses these properties the next time you create an
object of this type.
Modifies the selected objects using the current properties of
the dialog box.
Fills the dialog box with the properties of the selected object.
If several objects are being selected, Tekla Structures takes
the properties randomly from one of them.
Switches all check boxes in the dialog box on and off.
Closes the dialog box without saving the properties or
modifying objects.
Saves the properties in the file shown in the list.
Loads the previously saved properties to the dialog box.
Tekla Structures also loads the properties of sub-dialog
boxes, even if they are not open. Select the name of the
properties file you want to use.
For more information, see Save and load object properties.
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Button

Description
Saves the properties with the name given in the box. The
Save as button also updates the Load list. This is important
if you add or delete files manually.
Tekla Structures stores the properties files in the model
folder, also including the properties of sub-dialog boxes.
For more information, see Save and load object properties.

5.13 Change the language
You can change the language of the Tekla Structures user interface at any
time.
1.

On the File menu, click Settings --> Change language.

2.

Select a language from the list.
You have the following options. The three-letter language codes that are
given in parentheses are used in some language-dependent file and folder
names.
•

Chinese – simplified (chs)

•

Chinese – traditional (cht)

•

Czech (csy)

•

Dutch (nld)

•

English (enu)

•

French (fra)

•

German (deu)

•

Hungarian (hun)

•

Italian (ita)

•

Japanese (jpn)

•

Korean (kor)

•

Polish (plk)

•

Portuguese (ptg)

•

Portuguese – Brazilian (ptb)

•

Russian (rus)

•

Spanish (esp)

3.

Click OK.

4.

Restart Tekla Structures for the change to take effect.
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5.14 Take screenshots
A screenshot is an image of a model or drawing view. You can use screenshots
in posters, brochures, or other material to show projects carried out using
Tekla Structures.
By default, the screenshots are saved in the \screenshots folder under the
current model folder with the name snap_xx.png.

Take a screenshot of a model

You can take screenshots of model views.
1.

Open a model and adjust the model view according to your needs.
For example, hide the work area box if you do not want to show it.

2.

On the View tab, click

3.

If you have multiple views of the model, click Pick view and select the
view to take the screenshot from.

4.

To modify the settings, click Options.

5.

Screenshot --> Screenshot.

a.

Define the width, height, and DPI of the screenshot.

b.

Click OK to save the changes.

Define a name and location for the screenshot.
a.

Select Print to file and enter a descriptive name for the screenshot in
the File name box.
You can also change the whole path. If you do not want to do this, you
can keep the default values for the path and the file name.

6.

Click Show with associated viewer to show the screenshot in an
application that is by default associated with this file type.

7.

Click Capture.

Take a screenshot of a drawing

A drawing screenshot is an image of an open drawing with or without borders.
1.

Open a drawing and adjust the drawing view according to your needs.
For example, delete unnecessary marks or dimensions, and hide
unnecessary parts.
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2.

On the Views tab, click

3.

Do one of the following:

4.

Screenshot --> Screenshot.

•

Select View to take a screenshot of the open drawing with window
borders

•

Select View without borders to take a screenshot of the open drawing
without window borders.

Under the preselected Print to file option enter a descriptive name for
the screenshot in the File name box.
You can also change the whole path. If you do not want to do this, you can
keep the default values for the path and the file name.

5.

Click Show with associated viewer to show the screenshot in an
application that is by default associated with this file type.

6.

Click Capture.

Save a screenshot in bitmap format

By default, screenshots are created as Portable Network Graphics (.png) files.
You can also save a screenshot in bitmap (.bmp) format to use it, for example,
as a custom component thumbnail.
1.

On the Views tab, click

2.

Select Place on clipboard.

3.

Click Capture.

4.

Paste the screenshot in your graphics editor and save it in .bmp format.

Screenshot --> Screenshot.

NOTE The software that you use to open the screenshot may have a limit for the
number of pixels.

Screenshot settings

Use the Screenshot dialog box to view and modify the screenshot settings.
The following options are available in model views and in drawings.
Option

Description

View name

Shows the selected view name.

View

Includes the view content and window
borders in the screenshot.
Not available in model views.
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Option

Description

View without borders

Includes only the view content in the
screenshot.
Not available in model views.

Rendered view

For high resolution screenshots from
model views. The Options button
displays the Screenshot Options
dialog box.
Not available in drawings.

Place on clipboard

Places the screenshot on the
clipboard.
Not available in drawings.

Print to file

Saves the screenshot to a file.

The following screenshot options are only available in model views:
Option

Description

Final width

The width of the screenshot.
The units depend on the settings in
File menu --> Settings --> Options -> Units and decimals.

Final height

The height of the screenshot.
The units depend on the settings in
File menu --> Settings --> Options -> Units and decimals.

DPI

The pixel density (DPI) of the
screenshot.
There are limitations to pixel density.
You can change the DPI using a
graphics editor.

White background

Uses white background.

Smooth lines

Uses smooth lines to decrease jagged
edges.

Line width

Sets the line width.
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6

Contact Tekla Structures
support (Support tool)

The Support tool allows you to contact Tekla Structures support directly. With
this tool you can collect the model, related files, and other necessary
information in one support request, and safely upload your request to Tekla
Structures support.
The Support tool:
•

Automatically identifies the open model and includes all files or selected
files according to your selection from the model folder as attachments to
your request. Some logs and files in other folders are also attached, such
as the user feedback log, Tekla Structures logs and user-defined attribute
files.

•

Automatically gathers application and system information.

•

Uploads the problem description, attached model, attached files, and all
other gathered information to Tekla Structures support.

NOTE Confidentiality information
All files you upload are treated as confidential. Only the recipient can access
the files.

6.1 Create a support request
1.

On the File menu, click Help --> Contact Tekla support .
If you are having problems in opening Tekla Structures, you can use the
Start menu/Start screen to start the Support tool. The command to use
is Support tool.

2.

Log in using your Trimble Identity.
The Support tool opens and automatically fills in user, application and
Tekla Structures version information. Support tool reads your name, email
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address, company name and support email address from your Trimble
Identity profile.
You can switch to another account by clicking Switch user.
3.

Select a category from the list of predefined categories, or select Other
and enter the category.

4.

Enter the problem description.

5.

Click Next.

6.

Select what you want to attach. The file name, file group, file size, and file
location are mentioned for each file.

7.

•

Select the All check box, or select specific files from the Select the
files list.

•

If you want to send some other attachments than shown in the Select
the files list, click the Add extra files button and browse for the files.

•

To add crash dumps, click Add crash dumps.

Click Next.
The Support tool creates the package and shows the total attachment
size. You can also check application information and operating system
information before finalizing the support case creation.

8.

Click Create case to upload your case to Tekla Structures support.

When the upload is complete, you will receive a notification at your email
address. After a successful upload, an automatic confirmation message will be
sent to you, and then Tekla Structures support will start solving your case.
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